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Troubleshooting TCP Unidirectional Data Transfer Throughput: Packet Trace Analysis Using Wireshark

This paper is for developers, advanced admins, and tech support specialists who want to troubleshoot
TCP data transfer throughput issues that can affect the performance of customers’ or their own VMware
vSphere® environments.

Introduction

Data transfer over TCP is very common in vSphere environments. Examples include storage traffic
between the VMware ESXi™ host and an NFS or iSCSI datastore, and various forms of vMotion traffic
between vSphere datastores.

We have observed that even extremely infrequent TCP issues could have an outsized impact on overall
transfer throughput. For example, in our experiments with ESXi NFS read traffic from an NFS datastore, a
seemingly minor 0.02% packet loss resulted in an unexpected 35% decrease in NFS read throughput [1].

In this paper, we describe a methodology for identifying TCP issues that are commonly responsible for
poor transfer throughput. We capture the network traffic of a data transfer into a packet trace file for
offline analysis. This packet trace is analyzed for signatures of common TCP issues that may have a
significant impact on transfer throughput.

The TCP issues considered include packet loss and retransmission, long pauses due to TCP timers, and
Bandwidth Delay Product (BDP) issues. We use Wireshark to perform the analysis and provide a
Wireshark profile to simplify the analysis workflow. We describe a systematic approach to identify
common TCP issues with significant transfer throughput impact, and recommend engineers
troubleshooting data transfer throughput performance to include this methodology as a standard part of
their workflow.

We assume our readers to be familiar with the relevant TCP concepts described in this paper and have a
good working knowledge of Wireshark. For additional information about these topics, refer to the
SharkFest Retrospective [2] page of recent SharkFest Conferences.
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Things to Know Before Starting

Notation used

e S: Sender

e R: Receiver

About unidirectional data transfer

Consider unidirectional data transfer from sender S to receiver R over TCP.
Network traffic consists of the following:

e Datasegments:S 2> R

e ACK, duplicate ACK:R> S

e Retransmit:S > R

e TCP zerowindow: R > S

Wireshark Profile: TcpTransferTput

In this paper, we use the profile TcpTransferTput (a zip file) to simplify identifying many TCP issues that
impact data transfer throughput. You can find a detailed description of the profile in the appendix section
“Wireshark Profile: TcpTransferTput.”

To use this profile:

1. Download the profile (zip file) at
https://www.vmware.com/content/dam/digitalmarketing/vmware/en/pdf/techpaper/performance/
TcpTransferTput.zip

2. In Wireshark:
a. Edit > Configuration Profiles > Import 2> from zip file

b. Edit > Configuration Profiles > TcpTransferTput
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Troubleshooting TCP Unidirectional Data Transfer Throughput: Packet Trace Analysis Using Wireshark

Performance Anomalies

In this section, we describe signatures of performance anomalies that have a significant impact on data
transfer throughput.

Classes of performance anomalies for data transfer throughput

There are three classes of performance anomalies for data transfer throughput:

e Packet Loss, Out of Order: This class includes packet loss, out of order, duplicate ACKs, and fast and
slow retransmissions. Wireshark issues TCP warnings about these anomalies.

¢ Long Pause, High Latency: This class includes TCP timer-related anomalies, such as delayed ACK or
Nagle delay. These anomalies typically consist of long repeated pauses of the same duration.

e Bandwidth Delay Product: This class consists of anomalies regarding the interaction of the number of
bytes sent but not yet acknowledged, receive window size, and TCP send and receive buffer sizes.
There is no packet loss, no retransmission, and no long pause.

Table 1 summarizes the characteristics of these classes of performance anomalies.

Class

Characteristics

Highlight

Packet Loss, Out of Order

Retransmit (fast, slow)

Wireshark TCP warnings

Long Pause, High Latency

TCP timers, network latency, storage
latency

Timer-based

Bandwidth Delay Product

Bytes in flight, receive window, Slow
Start

No Wireshark warnings, no long

pauses

Table 1. Classes of performance anomalies

|dentification of performance anomalies using Wireshark

The following table shows various methods of identifying performance anomalies using Wireshark: Expert
Info, Display Filter, Tcptrace graph, and 1/O graphs (from the TcpTransferTput profile).

Class Detail Wireshark: Column Wireshark: Display Filter Wireshark: Info
(Packet List pane) (Time in seconds) Feature

Packet DUP ACK tcp.analysis.duplicate_ack Expert Info Require trailing
Loss, Out segment(s)
of Order e DUP ACK

3x DUP ACK tcp.analysis.duplicate_ack_num >= | ® Outoforder | poqire 3+ trailing

3 e Fast retransmit | segments
e Retransmit

Out of order tcp.analysis.out_of_order

Fast tcp.analysis.fast_retransmission

retransmit

Slow tcp.analysis.retransmission
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Class Detail Wireshark: Column Wireshark: Display Filter Wireshark: Info
(Packet List pane) (Time in seconds) Feature
retransmit .
(RTO) tcp.analysis.flags
Long Inter-frame frame.time_delta_displayed | (frame.time_delta > 0.001) Tcptrace graph
Pause, time
High e Long pause
Latency TCP RTO frame.time_delta_displayed | (frame.time_delta > 1)
Timer
TCP Delayed | frame.time_delta_displayed | (frame.time_delta > 0.1)
ACK Timer
Network tcp.analysis.initial _rtt (tcp.analysis.initial _rtt > 0.01) TCP 3-way
iRTT latency handshake
Network tcp.analysis.ack_rtt (tcp.analysis.ack_rtt > 0.01)
ACK RTT
latency
Storage NFS | rpc.time (rpc.time > 0.01)
Call-Reply
latency
Storage scsi.time (scsi.time > 0.01)
iSCSI
Request-
Response
latency
Bandwidth Receiver tcp.window_size Tcptrace graph from receiver
Delay window size
Product (scaled) e Bytes In Flight
¢ Receive
Sender tcp.analysis.bytes_in_flight window from sender
BytesInFlight I/O graphs

(TcpTransferTput

profile)

Obs Point:

Closer to Sender
tcp.analysis.zero_window from receiver
tcp.analysis.window_ full from sender
tcp.analysis.zero_window_probe from sender

Table 2. Methods of identifying performance anomalies using Wireshark

Note: The time values in Display Filter expressions here (for example, [(rpc.time > 0.01)]) are for

illustration only. You should use values that are reasonable for your environment.

Regarding long pauses:

e TCP timers are typically in some round number of milliseconds (for example: 10ms, 200ms), so they are
easy to identify.

vmware
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¢ Known interactions leading to long pauses (not an exhaustive list):

— Nagle (delayed send) interacts with Delayed ACK. See the explanation by Hansang Bae: Wireshark
Tutorial of TCP Nagle and Delayed ACK Interaction [3].

- Slow Start interacts with Delayed ACK. Refer to NFS Read: Slow Start vs Delayed ACK [1].

These deadlocks are eventually broken by typically slow TCP timers, resulting in poor throughput.

Class Characteristics Signature Identification using Wireshark
Packet Loss, Out of Order Retransmit (fast, slow) Expert Info: DUP ACK, out of order, fast retransmit,
retransmit

Display Filter: from TcpTransferTput profile

Long Pause, High Latency TCP timers, network latency, storage Tcptrace graph: long pause
latency
Display Filter: from TcpTransferTput profile

Bandwidth Delay Product Bytes in flight, receive window, Slow Tcptrace graph: bytes in flight, receive window
Start
1/O Graphs: from TcpTransferTput profile

Observation Point: Closer to Sender

Table 3. Summary of signature identification

Wireshark Analysis

The following sections step through the Wireshark analysis methodology we use.

High-level workflow

Use Wireshark to identify performance anomaly signatures by following this workflow (we’ll describe the
details in the following sections):

1. Note packet capture conditions and capture drops.
2. Note packet trace file stats and TCP connections.
3. Export the selected TCP connection to a packet trace file.

4. ldentify performance anomalies using signatures.

Step 1: Note packet capture conditions and capture drops

In this step, we review key information about the packet capture process. You will use this information to
estimate whether the packet trace file is an accurate representation of the network traffic you are
analyzing.
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Troubleshooting TCP Unidirectional Data Transfer Throughput: Packet Trace Analysis Using Wireshark
Review the following:

1. Packet capture details

o Where were packets captured?

- On a network endpoint (for example: on an ESXi vmknic using [ccpdump-uw| OF pktcap-uw)

— Via an inline network tap on the physical network

- Via the mirror/SPAN port of a physical network switch
e Was a hardware packet capture system used?

e Observation point: Was the capture performed closer to the sender or the receiver on the network?

2. Experiment conditions
e Was the performance anomaly being investigated observed during capture?

¢ What was the time of day of the anomaly?

3. Capture drops

e Capture drops are packets in the traffic being analyzed but are not included in the packet trace file, due
to limitations of the packet capture process. Capture drops are common in endpoint captures and
could make packet trace analysis significantly more challenging.

e You can identify capture drops in a packet trace file using Wireshark as follows:

- In Wireshark, open the packet trace file. For example:

Use the Display Filter

|(tcp.analysis.lost_segment || tcp.analysis.ack_lost_segment)|

which is predefined as the Display Filter button TcpCapDrops in the TcpTransferTput profile.

For more information about packet capture, refer to our paper ESX |IP Storage Troubleshooting Best
Practice: Packet Capture and Analysis at 10G [3].

Step 2: Note packet trace file stats and TCP connections

In this step, we examine the number of bytes, number of packets, and duration of the packet trace file.
1. In Wireshark, open the packet trace file. For example:
2. Go to Statistics > Capture File Properties and note the following:

— Time: First Packet (Time of Day)

- Statistics: Packets, Time Span (duration), Bytes
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Troubleshooting TCP Unidirectional Data Transfer Throughput: Packet Trace Analysis Using Wireshark
For each TCP connection in the file, examine similar statistics and identify the data transfer direction.
1. In Wireshark, go to Statistics > Conversations > TCP.
Per connection:
a. Note the Packets, Bytes, and Duration.

b. Identify the data transfer direction (A - B or B > A), which will have higher bytes than the other
direction.

Step 3: Export the selected TCP connection to a packet trace file

In this step, we select a TCP connection of interest based on, say, the endpoint IPs and ports, or the
number of packets or bytes. We then export all the packets of this TCP connection to a new packet trace
file. Finally, we perform further analysis of this selected TCP connection on the new packet trace file. This
is an optional but recommended step—it simplifies some of the subsequent analysis steps in Wireshark. If
we have multiple TCP connections of interest, we need to export each connection to a separate packet
trace file for further analysis.

1. Select the TCP connection of interest with the desired endpoint IPs and ports.

Note: If you identify multiple connections of interest, you will need to select (and export) each
connection separately.

2. Select all frames of one TCP connection of interest. There are two ways to go about this:
Method 1

a. Inthe Wireshark Packet List pane, select one frame from the TCP connection of interest.

b. Use the Display Filter [(tcp.stream == ${tcp.stream})| Which is predefined as the Display Filter

button TcpStream in the TcpTransferTput profile.

c. |If the Packet List pane is sorted by some column other than the frame.number (No.) column—the
leftmost column—revert to sort by the frame.number column.

Method 2
a. In Wireshark, go to Statistics > Conversations > TCP and select one connection.

b. Select Apply as Filter > Selected - Filter on stream id. The Packet List pane now shows only
frames of the selected TCP connection.

3. Export the displayed frames to a new packet trace file by selecting File > Export Specified Packets.

— The file name should be in the form [xyz.connection=2?.pcapng.gZ|

- Save as type: Wireshark/... pcapng
- Compressed with gzip: Y
— Select All packets.

- Select Displayed.
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Step 4: Identify performance anomalies using signatures

In this step, we use different Wireshark features to identify various performance anomaly signatures. The
features used include:

e Display Filter

e Tcptrace graph

e /O graphs

The use of these features will be described in the following sections.

I Note: We assume that the packet trace file contains packets from one TCP connection.

Use Display Filter Signatures

Here, we use predefined display filters (from the TcpTransferTput profile) to identify performance anomaly
signatures.

1. lterate over the predefined display filter buttons to identify performance anomaly signatures.

2. If some frame (F) matches a signature, analyze the TCP connection frame F belongs to. Examine frame
F and successively earlier frames in the TCP connection until you discover the underlying issue.

3. For each performance anomaly identified in a TCP connection, determine if the frequency and severity
of the anomaly together results in a significant impact on transfer throughput.

Example: An instance of packet loss followed by fast retransmit does not always lead to a significant
decrease in transfer throughput.

Table 4 shows performance anomaly signatures and the corresponding display filters.

Class Display Filter Button | Display Filter Expression Direction
Packet Loss, Out of Order | TcpDupAck3+ tcp.analysis.duplicate_ack_num >=3 R->S
TcpRetrans(F/S) tcp.analysis.fast_retransmission || tcp.analysis.retransmission | SR
TcpOO tcp.analysis.out_of_order SR
Long Pause, High Latency | Pause=1+ms frame.time_delta > 0.001 (any)
Pause=10+ms frame.time_delta > 0.01 (any)
Pause=100+ms frame.time_delta > 0.1 (any)
Bandwidth Delay Product | TcpWinFull tcp.analysis.window_ full SSOR
TcpZeroWin tcp.analysis.zero_window R->S

Table 4. Performance anomaly signatures and their corresponding display filters
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Example: For the anomaly signature TCP triple duplicate ACK (which would trigger a TCP fast retransmit),
you will use the following analysis steps:

1. Use the Display Filter [(tcp.analysis.duplicate ack num >= 3)| Which is predefined as the Display Filter

button TcpDupAck3+ in the TcpTransferTput profile.

2. Select one matching frame (F) in the Packet List pane.

3. Click the Display Filter [(tcp.stream == ${tcp.stream})| Which is predefined as the Display Filter button

TcpStream.
This shows all frames of the TCP connection containing frame F.

4. Investigate: Examine earlier frames in the current TCP connection, beginning with frame F.

Use Tcptrace graph signatures

Here, you will use the Wireshark Tcptrace graph to identify signatures of two classes of performance
anomalies:

¢ Long pause (of multi-millisecond duration) between frames, typically due to TCP timers
e Bandwidth Delay Product (BDP) issues
Refer to the appendix section “Wireshark: Tcptrace graph” for an overview.

There are three different signatures to look for: one for long pauses due to TCP timers, and two for BDP
issues.

Signature 1: Long pauses due to TCP timers

To identify these pauses, inspect the Tcptrace graph of the connection. The characteristics to look for
include:

e Recurring pauses of identical duration.

e TCP timer values are typically in a round number of milliseconds (for example: Ims, 10ms, 200ms).
To use the Tcptrace graph to identify long pauses:

1. In Wireshark, go to Statistics > TCP Stream Graphs 2> Time sequence (tcptrace).

2. Switch Direction if necessary so that the Tcptrace graph is in the data transfer direction. See the
IPX:portX = IPY:portY line at the top of the Tcptrace graph.

3. Look for long, recurring pauses of identical duration between the frames. These appear as relatively
long horizontal line segments in the Tcptrace graph, as shown in Figure 1.
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Sequence Numbers (tcptrace) for 10.13.34.60:2049 — 10.96.123.217:975
example, 1-615K. pcapng. gz

el

57.5 58.5 59.5

Time {s)

Figure 1. An example of a Tcptrace graph that indicates long pauses

Signature 2: BDP receiver bottleneck

TCP segments frequently fill up the receive window. That is, the "I"-beams come close to the upper line,
as shown in Figure 2. This suggests a receiver bottleneck.

683000000

687000000

686000000

Sequence Number (B)

685000000

684000000

683000000

Sequence Numbers {tcptrace) for 192.168.0.1:13397 — 192.168.0.101:902
example. full, 1-1M.peapng. gz

vmware

L I I I L
29.725 29.75 29.775 29.825 29.875

29.85
Time (5)

Figure 2. Example of a Bandwidth Display Product receive bottleneck graph
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Troubleshooting TCP Unidirectional Data Transfer Throughput: Packet Trace Analysis Using Wireshark

Signature 3: BDP sender bottleneck

TCP segments rarely fill up the receive window, (that is, the "I"-beams are nowhere close to the upper
line). This suggests a sender bottleneck.

Sequence Numbers (tcptrace) for 192, 168.0.101:13904 — 192, 168.0.1:902
example.not-full. 1-1M.pcapng.gz

330000000
870000000 -

-
860000000 |- e

Sequence Number (B)
)
]

850000000 - i P

40000000 |- p pacret

[

830000000 -

I I I I I
33.2 33.4 33.6 33.8 34
Time (8)

Figure 3. Example of a Bandwith Display Product sender bottleneck

To use the Tcptrace graph to identify BDP issues:
1. In Wireshark, go to Statistics > TCP Stream Graphs > Time sequence (tcptrace).

2. Switch Direction if necessary, so the Tcptrace graph is in the correct data transfer direction.

3. Determine visually if the TCP segments fill up the receive window.

Use I/O graph signatures

In this section, we use predefined I/O graphs (from the TcpTransferTput profile) to identify signatures of
Bandwidth Delay Product-related performance anomalies.

Note: This section is not an exhaustive treatment of BDP. In particular, the following will not be covered:
BDP = Bandwidth * RoundTripTime
Comparing SendBufferSize to BDP

Comparing ReceiveBufferSize to BDP
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Table 5 describes the predefined I/O Graphs from the TcpTransTput profile.

Graph Metric Direction | Color Info

BytesInFlightMax | tcp.analysis.bytes_in_flight | SR Green | Bytes sent but not acknowledged

CalcWinSizeMax | tcp.window_size R->S Red Scaled receive window size

TcpWinFull tcp.analysis.window _ full S>R Blue Wireshark thinks sender has filled advertised window
TcpZeroWin tcp.analysis.zero_window R->S Purple | Receiver announces receive window is zero

Table 5. Predefined I/O Graphs from the TcpTransTput profile

The TcpTransTput profile predefines 2 sets (X, Y) of 4 I/O graphs each, for the two potential directions of
data transfer, respectively.

e Set X: BytesInFlightMaxX, CalcWinSizeMaxX, TcpWinFullX, TcpZeroWinX

e SetY: BytesInFlightMaxY, CalcWinSizeMaxY, TcpWinFullY, TcpZeroWinY

¢ Statistics > 1/0 Graphs

- Enable the 4 graphs of set X (or set Y) as appropriate

- Interval: Ims

— Log scale: (Yes: easier to observe non-zero TcpWinFull* or TcpZeroWin*)

— Automatic Update: Yes

Signature 4: Receiver may be the bottleneck if any of the following is observed:

e BytesIinFlightMax is frequently close to the max of CalcWinSizeMax.

e TcpWinFull is non-zero

e TcpZeroWin is non-zero

vmware
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Example A: Receiver bottleneck

Figure 4 shows an example I/O graph of linear scale with a receiver bottleneck.

Wireshark 1/0 Graphs: example. 1-1M.pcapng.gz

250000 — BytesInFlightMaxY
— CalcWinsizeMaxY
— TepWirFully
— TepzeroWint

200000

150000

100000

50000

Time (s)

Figure 4. Example 1/O graph showing receiver bottleneck (linear scale)

Figure 5 shows an example I/O graph of log scale with a receiver bottleneck. Note the non-zero values of
TcpWinFull and TcpZeroWin at the bottom.

Wireshark 1/0 Graphs: example. 1-1M.pcapng. gz
250000
200000 i Ukl
150000 [ 4

100000 — BytesIrFlightMaxy

50000 ’—] ——— CalcWinSizeMaxY

——— TpWinFully
— TepZeroWiny

Time (5}

Figure 5. Example I/O graph showing receiver bottleneck (log scale)
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Wireshark I/0 Graphs: example. 1-1M.pcapng. gz
{ T 1 N
1 [T VN [
| | s B \‘l T

\| | “ |—\““.'

gl \‘ (] |1

M
|

260000 |- [[| —— BytesiFightmaxy [
—— CalcWinSizeMax
|| —— Towinruy ‘

|| —— Tezerown

240000 i

220000 |- |

200000

180000

L
18

Time (s)

Figure 6. Example I/O graph showing receiver bottleneck (linear scale, zoomed in)

From figures 4-6, we can make the following observations:

¢ BytesInFlightMax is frequently very close to CalcWinSizeMax.

e TcpWinFullis frequently non-zero.

This indicates a receiver bottleneck.

Signature 5: Sender may be the bottleneck if the following is observed:

e BytesIinFlightMax is always significantly lower than CalcWinSizeMax.
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Example B: Sender bottleneck

Figure 7 shows an example I/O graph of linear scale with a sender bottleneck.

Wireshark 1/0 Graphs: example. 1-1.6M.pcapng.gz.gz

——— BytesInFlightMaxy
— CalcWinSizeMaxY
——— TeWinFully
— TepZeroWin¥

2108

1.5-105 |

500000

Time (s)

Figure 7. Example I/O graph showing sender bottleneck (linear scale)

Figure 8 shows an example I/O graph of log scale with a sender bottleneck.

Wireshark 1/0 Graphs: example. 1-1.6M.pcapng.gz.gz

24105 F

1.510% f i ) L ! 1

108 |

——— BytesInFlightMaxy

500000 |- — CalcWinSizeMax
——— ToWinFully
— TepZeroWin¥

Time (s)

Figure 8. Example I/O graph showing sender bottleneck (log scale)

vmware
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In figures 7 and 8, we can make the following observation:
e BytesInFlightMax is never close to CalcWinSizeMax

This indicates a sender bottleneck.

Conclusion

We have developed a methodology for identifying TCP issues that commonly lead to poor unidirectional
data transfer throughput. We captured the network traffic of the data transfer into a packet trace file for
offline analysis. We then analyzed this packet trace to detect signatures of common TCP performance
anomalies that have a significant impact on transfer throughput. The TCP issues we considered include
packet loss and retransmission, long pauses caused by TCP timers, and Bandwidth Delay Product (BDP)
issues. We performed the analysis using Wireshark and provided a Wireshark profile to simplify the
analysis workflow. This methodology offers a systematic approach to identify common TCP issues that
have a significant impact on transfer throughput. We encourage engineers troubleshooting data transfer
throughput performance to incorporate this methodology as a standard part of their workflow.

Appendix

Wireshark profile: TcpTransferTput

We provide the Wireshark profile TcpTransferTput, which provides predefined Display Filters and 1/O
graphs that help you identify TCP performance anomaly signatures that impact data transfer throughput.

To use this profile:
1. Download the profile (zip file) [4]

https://www.vmware.com/content/dam/digitalmarketing/vmware/en/pdf/techpaper/performance/
TcpTransferTput.zip

2. In Wireshark: Edit > Configuration Profiles > Import > from zip file.

3. In Wireshark: Edit > Configuration Profiles > TcpTransferTput

High level of using the TcpTransferTput profile:

1. ldentify TCP performance anomaly signatures that impact data transfer throughput.
2. Display Filters: Predefined filters for performance anomaly signatures.

3. I/O Graphs: Predefined graphs for Bandwidth Delay Product anomaly signatures.

I Note: We assume that the packet trace file contains only one TCP stream.
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Packet List pane: Columns

The following columns are selected to simplify various TCP analysis:

¢ DeltaTime: The time between the current frame and the previous frame in the same TCP connection.

¢ DeltaTimeDisplayed: The time between the current frame and the previous frame is displayed in this

pane.

— This is useful if some Display Filter is in use and not all frames are displayed.

- Example: DisplayFiIter: |(tcp.analysis.duplicate_ack_num>:3) | (tcp.analysis.fast_retransmission)l

e Seq: Sequence number

e Ack: ACK number

e TcplLen: Payload size

e CalcWinSize: Scaled receive window size

e BytesiInFlight: Bytes sent but not acknowledged

Packet List pane: Display Filters predefined (buttons)

The following Display Filters are predefined to simplify anomaly signature identification.

vmware

Button Filter Expression

TcpDupAck3+ (tcp.analysis.duplicate_ack_num >= 3)

TcpRetrans(F/S) | (tcp.analysis.retransmission || tcp.analysis.fast_retransmission)
TcpOO (tcp.analysis.out_of_order)

Pause=1+ms

(frame.time_delta > 0.001)

Pause=10+ms

(frame.time_delta > 0.01)

Pause=100+ms

(frame.time_delta > 0.1)

TcpWinFull (tcp.analysis.window_ full)

TcpZeroWin (tcp.analysis.zero_window)

TcpStream (tcp.stream == ${tcp.stream})

TcpCapDrops (tcp.analysis.lost_segment || tcp.analysis.ack_lost_segment)

Table 6. Display Filter buttons and their corresponding filter expressions
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I/O graphs are predefined for Bandwidth Delay Product-related anomaly signature identification.

Graph DisplayFilter Style | YAxis YField

BytesInFlightMaxX | tcp.srcport < tcp.dstport) Line | MAX(Y Field) tcp.analysis.bytes_in_flight
CalcWinSizeMaxX | tcp.srcport >= tcp.dstport) | Line | MAX(Y Field) tcp.window _size
TcpWinFullX tcp.srcport < tep.dstport) Line | COUNT FRAMES(Y Field) | tcp.analysis.window_full
TcpZeroWinX tcp.srcport >= tcp.dstport) | Line | COUNT FRAMES(Y Field) | tcp.analysis.zero_window
BytesInFlightMaxY | tcp.srcport >= tcp.dstport) | Line | MAX(Y Field) tcp.analysis.bytes_in_flight
CalcWinSizeMaxY | tcp.srcport < tcp.dstport) Line | MAX(Y Field) tcp.window_size
TcpWinFullY tcp.srcport >= tcp.dstport) | Line | COUNT FRAMES(Y Field) | tcp.analysis.window_full
TcpZeroWinY tcp.srcport < tcp.dstport) Line | COUNT FRAMES(Y Field) | tcp.analysis.zero_window

Table 7. I/O graphs predefined in TcpTransferTput profile

The TcpTransTput Wireshark profile predefines 2 sets (X, Y) of 4 I/O graphs each, for the two potential
directions of data transfer respectively.

e SetY: BytesInFlightMaxY, CalcWinSizeMaxY, TcpWinFullY, TcpZeroWinY

e Data transfer direction (srcport => dstport)

Set X: BytesInFlightMaxX, CalcWinSizeMaxX, TcpWinFullX, TcpZeroWinX

— Set X: srcport < dstport (for example: 789 => 2049)

— Set Y: srcport >= dstport (for example: 2049 => 789)

e In Wireshark, go to Statistics > 1/O Graphs

- Enable the 4 graphs of set X (or set Y) as appropriate.

- Interval: Ims

— Log scale: (Yes: easier to observe non-zero TcpWinFull* or TcpZeroWin*)

— Automatic Update: Yes

vmware
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Wireshark: Tcptrace graph

The following table shows the key features of Wireshark's Tcptrace graph.

Graph Element Info

Vertical axis Sequence number

Upper line Highest sequence number sender is allowed to send
(green)

Lower line ACK number

(brown)

Tiny "I"-beams between lower and upper lines TCP segments
(dark blue)

Vertical distance between lower and upper lines | Scaled receive window size

Table 8. Key features of Tcptrace graph in Wireshark

Example: Identification using Display Filter signature

In this section, we describe the detailed steps for the identification and analysis of a Display Filter anomaly
signature related to a packet loss and TCP fast retransmission episode. The key steps are:

1. Use the Display Filter signature to identify TCP fast retransmission.
2. ldentify key frames of interest for a packet loss and fast retransmission episode.
- Lost segment (if found in the packet trace file)
— The 3rd (triple) duplicate ACK (which would trigger TCP fast retransmission on the sender)
3. Compute the delta time between the triple duplicate ACK and fast retransmit, and compare the delta
time with the initial Round Trip Time of the connection.
Highlights
e TCP
- Client: 172.16.64.15:29053

- Server:13.32.207.59:443
e Data Transfer

- Sender (S): 13.32.207.59:443

— Receiver (R): 172.16.64.15:29053
o Packet capture

— Observation Point is closer to receiver R (from TCP 3-way handshake)
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Packet trace analysis (example)

Identify key frames of interest

I Assumption: The packet trace file contains only one TCP connection.

Frame S/R Details Comments

Step 1: Signature for Fast/Slow Retransmit
Display Filter: TcpFastRetrans(F/S): (tcp.analysis.retransmission || tcp.analysis.fast retransmission)

1921 S->R  Seg=1572235,Len=1440 [TCP Fast Retransmission]
3646 S->R  Seqg=2964715,Len=1440 [TCP Fast Retransmission]
5323 S->R Seqg=4637995,Len=1440 [TCP Fast Retransmission]
# 1921 is fast retransmission
# Action: select Frame=1921 for further analysis
Step 2: DupAck#3
Display Filter: (tcp.ack == 1572235) && (tcp.analysis.duplicate ack num == 3)
1541 R->S Ack=1572235 [DupAck 1531#3]
# 1541 is DupAck#3
Step 3: DupAck#l
Display Filter: (tcp.ack == 1572235) && (tcp.analysis.duplicate ack num == 1)
1534 R->S Ack=1572235 [DupAck 1531#1]

# 1534 is DupAck#l

Step 4: Ack

Display Filter: (tcp.ack == 1572235) && (!tcp.analysis.duplicate_ ack)
1531 R->S Ack=1572235 [ACK]

1539 R->S Ack=1572235 [ACK] [TCP Window Updatel]

1688 R->S Ack=1572235 [ACK] [TCP Window Updatel]

# 1531 is Ack
Step 5: Lost Segment
Display Filter: (tcp.seqg == 1572235)

1233 S->R Seqg=1572235,Len=1440
1921 S->R Seg=1572235,Len=1440 [TCP Fast Retransmission]

4=

1233 is lost segment
# 1921 is Fast Retransmission

Note: we do not always observe the lost segment in the packet trace file.
Sender (S) => Observation Point (OP) => Receiver (R)

a. If segment was lost between S/OP: segment not in packet trace file

b. If segment was lost between OP/R: segment in packet trace file

H H H 3
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Step 6: Receiver caught up
Display Filter: (tcp.ack > 1572235)

2115 R->S Ack=1576555 [R caught up]

# Lost segment ACK'd

Step 7: Summary: Key frames of interest

1 R->S Syn [SYN]
2 S->R Syn/Ack [SYN, ACK]
3 R->S Ack [ACK]

1233 S->R Seg=1572235,Len=1440 [Lost segment: not arrive at R] *

1531 R->S Ack=1572235 [ACK]

1534 R->S Ack=1572235 [DupAck 1531#1]

1541 R->S Ack=1572235 [DupAck 1531#3] *

1920 R->S Ack=1572235 [DupAck 1531#30]

1921 S->R Seg=1572235,Len=1440 [TCP Fast Retransmission] *
1922 R->S Ack=1572235 [DupAck 1531#31]

2114 R->S Ack=1572235 [DupAck 1531#51]

2115 R->S Ack=1576555 [R caught up]

# Note: Not all frames are shown.
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Compare time from DupAck#3 to fast retransmit with iRTT

Frame

Step 8:

w

H FH H S

Step 9:
1541
1920
1921
1922

2114
2115

# DeltaTime:
# Important: Unset time reference after this analysis!!!

Time

S/R

Details Comments

Initial Round Trip Time (iRTT) of TCP 3-way handshake

0.000
0.015
0.016

iRTT:

R->S
S->R
R->S

160ms

Syn [SYN]
Syn/Ack [SYN, ACK]
Ack [ACK]
(0.016s)

This example:
+ TCP client is Receiver
+ TCP server 1is Sender

Set time reference at DupAck#3 (Frame=1541)

*REE*

0.018
.019
0.019

o

0.024
0.024

R->S

R->S
S->R
R->S

R->S
R->S

Ack=1572235 [DupAck 1531#3]

Ack=1572235 [DupAck 1531#30]
Seqg=1572235,Len=1440 [TCP Fast Retransmission]
Ack=1572235 [DupAck 1531#31]

Ack=1572235 [DupAck 1531#51]

Ack=1576555 [R caught up]

DupAck#3 (Frame=1541)..Fast Retransmission

(Frame=1921) :

Delta time between DupAck#3 and Fast Retransmission is 19ms,
which is comparable with initial Round Trip Time of 1léms for the connection.
Frame=1921 is indeed a fast retransmission.

vmware
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Key frames of interest: details

No.
TCPLen

64240

65535
3
263424

1233
1440

1531
4013056
1532
1440
1533
1440
1534
4013056
1535
1440
1536
1440
1537
1440
1538
4013056
1539
4200448
1540
1440
1541
4200448

1920
4230656

1921
1440

1922
4230656

2114
4230656
2115
4230656

Time

DeltaTime

Source

CalcWinSize BytesInFlight Info

0.000000000

0.015451449

0.016156258

0.187764965
68096

0.194847383

0.194856671
68096
0.194868882
68096
0.194869650

0.194881086
68096
0.194893282
68096
0.194905506
68096
0.194958353

0.194959122

0.194974901

68096

0.194985089

0.213974920

0.214040303

68096

0.214116890

0.219340445

0.219375412

0.000000000
[SYN]
0.015451449

[SYN, ACK]

0.000704809
[ACK]

0.000012204
391680

0.000025576
[ACK]
0.000009288

375840
0.000012211
377280
0.000000768

172.16.64.15

13.32.207.59

172.16.64.15

13.32.207.59
[ACK]

172.16.64.15

13.32.207.59
[ACK]

13.32.207.59

172.16.64.15

[TCP Dup ACK 1531#1]

0.000011436
364320
0.000012196
365760
0.000012224
367200
0.000052847

13.32.207.59
[ACK]
13.32.207.59
[ACK]
13.32.207.59
[ACK]
172.16.64.15

[TCP Dup ACK 1531#2]

0.000000769

172.16.64.15

[TCP Window Update]

0.000015779
354240
0.000010188

13.32.207.59
[ACK]
172.16.64.15

[TCP Dup ACK 1531#3]

0.001065628

172.16.64.15

[TCP Dup ACK 1531#30]

0.000065383
478080
0.000076587

13.32.207.59

Destination

13.32.207.

172.16.64.

13.32.207.

172.16.64.

13.32.207

172.16.64.

172.16.64.

13.32.207.

172.16.64.

172.16.64.

172.16.64.

13.32.207.

13.32.207

172.16.64.

13.32.207

13.32.207.

172.16.64.

59

15

59

15

05

15

15

59

15

15

15

59

05

15

059

59

15

[TCP Fast Retransmission]

172.16.64.15

[TCP Dup ACK 1531#31]

0.000012552

172.16.64.15

[TCP Dup ACK 1531#51]

0.000034967
[ACK]

172.16.64.15

13.32.207.

13.32.207.

13.32.207.

59

59

59

SrcPort DstPort Seq

29053

443

29053

443

29053

443

443

29053

443

443

443

29053

29053

443

29053

29053

443

29053

29053

29053

443

29053

443

29053

443

29053

29053

443

29053

29053

29053

443

443

29053

443

443

29053

443

443

443

1572235

2772

1959595

1961035

2772

1962475

1963915

1965355

2772

2772

1966795

2772

2772

1572235

2772

2772

2772

Ack

2772

1572235

2772

2772

1572235

2772

2772

2772

1572235

1572235

2772

1572235

1572235

2772

1572235

1572235

1576555

I Note: Packet trace file provided by www.bettydubois.com.
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